Applies to:
Trust Protection Platform version 20.3 - 22.2
Symptom:
Error occurs if customer is mid upgrade and have not yet upgraded all of their TPP servers but are trying to run TPP during the upgrade.
Cause:
There is a process that is done near the end of the upgrade that has not completed yet.
Resolution:
Complete upgrading all of your TPP servers. Until all of the servers in your Platform tree are upgraded, the FULL upgrade process will not complete. You can verify the upgrade process is complete by selecting your icon at the top-right of the Web console and looking at the upgrade status. If it is not complete, if there are processes still running or blocked, this may occur.
NOTE: If you have systems in the Platform tree (Policy tree - Platforms) that you are not upgrading at this time, they should be removed. ALL servers must be upgraded for the upgrade to fully process and the migration tasks to complete.
If you are unable to upgrade all of them at this time, you could run a SQL query to fix the issue until you are able to finish the entire upgrade process, though this is not recommended.
Here is the query:
update config_policies set AttributeValue = 'Software' where Attribute = 'Encryption Driver' and AttributeValue = 'DPAPI';
update config_contains set AttributeValue = 'Software' where Attribute = 'Encryption Driver' and AttributeValue = 'DPAPI';
update config_policies set AttributeValue = 'Protection Key' where Attribute = 'DPAPI:Default' and AttributeValue = 'Software:Default';
update config_contains set AttributeValue = 'Protection Key' where Attribute = 'DPAPI:Default' and AttributeValue = 'Software:Default';
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