Applies to:
Trust Protection Platform version 20.3 - 22.2
Symptom:
Error occurs if customer is mid upgrade and have not yet upgraded all of their TPP servers but are trying to run TPP during the upgrade.
Cause:
There is a process that is done near the end of the upgrade that has not completed yet.
Resolution:
Complete upgrading all of your TPP servers. If you are unable to upgrade all of them at this time, you can run a SQL query to fix the issue until you are able to finish the entire upgrade process.
Here is the query:
update config_policies set AttributeValue = 'Software' where Attribute = 'Encryption Driver' and AttributeValue = 'DPAPI';
update config_contains set AttributeValue = 'Software' where Attribute = 'Encryption Driver' and AttributeValue = 'DPAPI';
update config_policies set AttributeValue = 'Protection Key' where Attribute = 'DPAPI:Default' and AttributeValue = 'Software:Default';
update config_contains set AttributeValue = 'Protection Key' where Attribute = 'DPAPI:Default' and AttributeValue = 'Software:Default';
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