Follow

Error: "This upgrade is not allowed due to an incompatible version of SQL Server"

Applies To:

Upgrading or installing Venafi Trust Protection Platform 17.4 or higher

Summary:

The following error is received while running the mssql_update_17.3_to_17.4.sql or CreateDB.sql scripts for TPP 17.4 (or later versions):

This upgrade is not allowed due to an incompatible version of SQL Server. Please upgrade to Microsoft SQL Server 2012 SP2 or newer.  For more information please see: https://support.venafi.com/hc/en-us/articles/115002764671

Resolution:

Microsoft SQL Server 2008 R2 is no longer compatible with Venafi Trust Protection Platform (TPP) beginning in version 17.4. This change was made to improve the security of TPP by leveraging newer database functionality not available in Microsoft SQL Server 2008 R2. Specifically, SQL Server 2008 R2 does not support SHA256 hashing algorithm, which Venafi is requiring in TPP 17.4 and later versions.

 

Supported versions of Microsoft SQL Server on TPP 17.4:

  • Microsoft SQL Server 2012 SP2
  • Microsoft SQL Server 2014

Compatible versions of Microsoft SQL Server on TPP 17.4:

  • Microsoft SQL Server 2016

 

See Also:

Info: End Of Support Announcement For MS SQL Server 2008 R2

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk