Symptom:
When attempting to use a Microsoft CA template object that is incorrectly configured you may get the following (or similar) popup error:
Commincation with the CA has failed, please check the settings before trying again. System error:CCertAdmin:GetCAProperty:The parameter is incorrect. 0x80070057 (WIN32: 87)
or
Communication with the CA has failed, please check the settings before trying again. System error: CCertAdmin:GetCAProperty:Class not registered 0x80040154 (-2147221164)
Cause:
This is likely due to the hostname and / or service name not being configured correctly. Neither one can be left blank.
Resolution:
Review the hostname and service name settings and correct as needed.
Comments
This error can also result from a slow DNS resolution. If the parameters are correct, do an nslookup on the hostname and check to see how long it takes to return a result. If more than two seconds, either enter the CA hostname into the hosts file or look for a DNS server with a quicker return.