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Issue: Duplicate pending workflow tickets

Symptom:

Workflow tree shows one or more duplicate workflow tickets:

duplicate_wf_tickets.PNG

Only approving or rejecting the newest ticket allows the process to continue. Approving or rejecting an older ticket makes the ticket disappear but the processing does not continue.

 

Cause:

This happens when approvers are changed for a pending workflow ticket. This applies to both object and policy level approver changes.

 

Resolution:

This issue will be resolved in a future version of Director. As a workaround we can approve or reject all the duplicate pending tickets at once. The duplicate tickets will disappear once processing continues or is restarted.

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