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Error: Venafi services won't start when using Windows Authentication

Symptom

When using Windows Authentication for the MSSQL database connection, the Venafi Services won't start.


Cause

The Venafi services are configured incorrectly. This usually means that the services are attempting to run as a local system account rather than a specific user account.


Resolution

Configure the services to use the same credentials that were specified for the database connection. For detailed steps, see below:

 


 

To modify the Venafi service settings in a Windows Authentication environment:

  1. Login as administrator or run each service as an administrator. (Administrator privileges are required to complete the following steps.)
  2. Click Start > Programs > Administrative Tools > Services.
  3. In the Local Services Control Panel list, double-click the Venafi Trust Protection Platform service.
  4. In the Properties dialog, click the Log On tab.service.png
  5. Select This account.
  6. Type the database user account or click Browse to select the database user account from the directory.
    The database user account is the account Venafi Director uses to connect to the database.
    **You must type the username using the domain name syntax (domain_name\username)
    or User Principle Name syntax (valid_user@orgUnit.domain.com).**

  7. Enter and confirm the account password.
  8. Click OK to apply the user Log On setting and exit the Properties dialog.
  9. Repeat Steps 3-8 for the Venafi Log Server service.
  10. Restart the Venafi Trust Protection Platform and Venafi Log Server services for the settings to take effect.
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