Applies to:
Version 6.x.
Symptom
When attempting to access context specific logging information by going to the General>Log tab of any object, a messages similar to the ones listed below is displayed:
A connection to the Log Server cannot be established
--or--
Unable to locate the DSN of the log server
Cause
There are two possible ways you can arrive at this symptom:
- After a fresh install of Certificate Manger, you may have configured the default SQL channel, but forgotten to configure logging for each node.
- On upgrading Director - from 6.0.2 to 6.1. The SQL channel was mis-configured. For example, you may have entered in "localhost" for the primary log server address, but for some reason Director could not find the log server. You resolved the problem by changing log server address from "localhost" to 127.0.0.1, however your nodes no longer show logging information.
Resolution
The majority of troubleshooting , for this symptom, is done in the logging tree.
- Within the Venafi Windows Console, navigate to the logging tree then down to the Channel node, and then the Default SQL channel. Note the two sets of credentials here - Database and Log View Database Access.
- Make sure that the correct information is used for the Log View Database Access section. In almost all cases, you can copy the credentials, host, and port from the Database section.
- Restart the Venafi Log Server service
Resolution:
For the logging events to be viewed in other trees, other than the logging tree, the second section mentioned in the troubleshooting section above has to be populated with accurate information. For troubleshooting purposes, Venafi has ensured that the logging information found in the the Default SQL channel is logging information for the whole Director server, whereas the logging information found on particular trees, or nodes, is filtered to only show logging for that node.
NOTE: for an article on how to setup log expiration see KB 20735267
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