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Error: HTTP Error 404 File or Directory not found message is displayed when accessing Aperture

Applies to:

All Trust Protection Platform versions

Venafi Encryption Director 9, 10, and 11

 

Symptoms:

When accessing Aperture portal, an HTTP error 404 File or Directory not message is displayed when accessing Aperture even though the service account has full permissions to the %Program Files%\Venafi folder and the files exist.

 Screen_Shot_2014-05-23_at_17.26.16.png

Using the URL https://localhost/Aperture, an HTTP error 404.7 File_Extension_Denied message is displayed

 Screen_Shot_2014-05-29_at_16.12.25.png

 

Cause:

This is caused by IIS not allowing unlisted extension to run. For more information refer to http://support.microsoft.com/kb/942045

 

Resolution:

As per the MIcrosoft KB, allowing unlisted extension to run resolve the problem.

To allow unlisted extension to run:

  1. Open File Explorer and go to %windir%\System32\inetsrv\config
  2. Create a backup copy of applicationHost.config
  3. Edit the applicationHost.config
  4. Search for <requestFiltering> section
  5. Change <fileExtension allowUnlisted="false"> to <fileExtension allowUnlisted="true">
  6. Save and restart IIS services
  7. Aperture should now be accessible

 

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