Applies To:
Trust Protection Platform 15.1
Symptom:
Unable to see the tree in Webadmin after upgrading to 15.1.
Reports tab shows as the default in the details view pane.
Cause:
The reason for this change is because of a new feature that was introduced in TPP (Trust Protection Platform) 15.1. We now set TPP automatically to "Large Tree Support" when there are objects totaling 60,000 (Certificate, Applications, Devices) in the tree.
Post 15.4 a setting has been made available in the Platforms tree that enables this by the click of a checkbox in the Platforms tree.
Resolution:
Post 15.4 You can click the Platforms tree and then click the "Support large object trees:" checkbox
The 60,000 threshold should be increased for any customer running into this situation. If "Large Tree Support" is desired a customer may set that option under preferences or the platforms tree.
Do the following to increase the threshold for the new feature.
- Open up windows explorer and browse to the Venafi/Web/Admin/ folder.
- Edit the web.config file with the following information.
Adding the following line between the <appsettings> tags.
<add key="LargeTreeThreshold" value="600000" />
Example:
<appSettings>
<add key="ChartImageHandler" value="storage=session">
</add>
<add key="LargeTreeThreshold" value="600000" />
</appSettings> - Logging into Webadmin should now work as expected.
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