Symptom:
Retrieve button on on Microsoft CA template objects returns an error:
"Communication with the CA has failed, please check the settings before trying again. System error: The server process could not be started because the configured identity is incorrect. Check the username and password. (Exception from HRESULT: 0x8000401A "
Cause:
There are two scenarios where this error would be expected:
1. The server does not have the “Microsoft CA Integration” component installed so there are no credentials to use for the connection.
2. The server has “Microsoft CA Integration” component installed but the credentials specified on “Venafi COM+ Service” in Component Services is invalid.
Resolution:
- Check that "Microsoft CA Integration" component is installed
- Check credentials used by "Venafi COM+ Service”
This issue is commonly seen on system that have only Web Administration Console installed. If we need to be able to configure MSCA templates through WebAdmin, the server needs to have the "Microsoft CA Integration" component installed.
Comments
If your issue is around the invalid credentials, (number 2 above) there are instruction for editing the COM+ object here:
https://venafi.zendesk.com/entries/21671441-Error-MS-CA-Authentication-error-when-pressing-Load-