Symptom:
When adding a Microsoft CA, you may get the error "Communication with the CA has failed, please check the settings before trying again. System error: CCertAdminGetCAProperty: The RPC Server is unavailable". This will be seen when trying to load the templates from the CA
Cause:
This can be caused because the identiy that the Venafi COM+ component uses does not have permissions to read, issue and manage certificates. This account should be a domain account, not a local account on the VED server.
Solution:
- Verify that the account used to access the CA is assigned Read and 'Issue and Manage Certificates' permissions on the CA.
Verify that the account listed in the 'Identity' tab of the Venafi COM+ component is the same account setup in step 1. Confirm the password is correct.
Verify that the Director and Log services are running as this user.
Also see https://support.venafi.com/entries/20877253-CA-Communication-Error-when-adding-an-MS-CA
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