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Error: The Venafi Trust Proctection Platform service fails to start with the error: "Windows could not start the Venafi Trust Protection Platform service on Local Computer. Error 1067: The process terminated unexpectedly."

Symptom:

When starting the Venafi Trust Protection Platform (VED) service, the service fails to start with the error:

Windows could not start the Venafi Trust Protection Platform service on Local Computer. Error 1067: The process terminated unexpectedly.

Cause:

This error will appear if someone mistypes an entry in the zone fields, it can prevent the Venafi Trust Protection Server service from starting.

Diagnostic:

  1. Login to WebAdmin, and go to the Logging Tree
  2. Expand Channels, and click on the Default SQL Channel
  3. Click on the General tab, and select Log View
  4. Check if there is an Alert error which contains:

    Fatal Exception 'An invalid IP address was specified.' was encountered
        at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
        at Venafi.Core.Address.Parse(String Address)
        at Venafi.Core.Zone.a()
        at Venafi.Core.Zone.ReadZone(Config config, Zone& zone)
        at Venafi.Discovery.Discovery.Run()
    .
    .

  5. If the above error is present, go to the Windows Application event logs (Event Viewer >Windows Logs > Applications)
  6. Search for an Error event, and check for the following error description:

    Description:
    Fatal Exception 'An invalid IP address was specified.' was encountered
        at System.Net.IPAddress.InternalParse(String ipString, Boolean tryParse)
        at Venafi.Core.Address.Parse(String Address)
        at Venafi.Core.Zone.a()
        at Venafi.Core.Zone.ReadZone(Config config, Zone& zone)
        at Venafi.Discovery.Discovery.Run()
    .
    .

  7. Those errors points to misconfigured Discovery zone(s) under the engine name in the Platforms tree.

Resolution:

  1. Open WebAdmin, and go to the Platforms tree
  2. Click on the engine which is having the issue with the Venafi Trust Protection Platform service not starting, and check the Discovery Zones section



  3. Edit the Discovery Zone, and ensure that the IP address ranges are valid IP ranges, and do not contain any invalid characters

    NOTE: Look for spaces, commas and alphabetical characters. The below entry has an extra space at the beginning of the IP address range.



  4. Correct the entry(s), and start the Venafi Trust Protection Platform service

 

 

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