Applies to
Venafi Trust Protection Platform 15.3+
Symptom
Logs are not being created and the only logs are from before the upgrade
Cause
There are many potential causes for this issue as logging has changed in 15.3 to use the database service broker for logging instead of sending logs to the log server over port 689.
One cause which has been found is if the SQL services on the DB server are running as a local system account and the Venafi services are setup to use an Active Directory account.
To test if this issue is the cause you can login to the database as local SQL account (not the affected AD service account) and run this command:
Enqueuelog 0x0
If affected you will see the following error:
could not obtain information about windows nt group/user 'your ad user' 0x5
Resolution
There are 2 possible resolutions:
- Change the SQL services to run as an AD account
- Change the Venafi services to run with a local account (includes deleting the old user from the database and re-creating any DB objects owned by said user.)
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