Follow

Introducing VCert - API Abstraction for DevOps

Venafi VCert is a command line utility designed to generate keys and simplify certificate acquisition by eliminating the need to write code to interact with Venafi REST APIs. As such, it is particularly well-suited for use in DevOps CI/CD pipelines where certificates are typically required by infrastructure and applications as (or immediately after) they are been deployed.  VCert is an open source project, written in the Go programming language, and includes release binaries for Linux, Windows, and macOS.

Getting Started

VCert is compatible with Venafi Cloud and Trust Protection Platform 17.3 and higher.  The Custom Fields and Instance Tracking features require TPP 18.2 or higher.  Token Authentication requires TPP 19.2 or higher; for earlier versions, username/password authentication (deprecated) applies.

The following documentation has been prepared to help you be successful using VCert:

Getting Help

The VCert open source project is community-supported. Please report suspected non-security bugs or enhancement ideas using Issues in the GitHub repository. Our goal is for the documentation we've provided, both online and output by VCert itself, to make you successful without needing additional help but we understand there is always room for improvement. Please direct any general questions, comments, or security related concerns to opensource@venafi.com.

Was this article helpful?
6 out of 6 found this helpful
Have more questions? Submit a request

Comments