Applies To:
Venafi Trust Protection Platform 16.2 and higher
Symptom
Viewing logs timeout
Cause
A large amount of log data fragments the database indexes and causes slow log view performance,
Solution
Use the following Microsoft SQL Server commands for re-indexing logging tables:
ALTER INDEX ALL ON DAL_T_LOG_LOG_MESSAGE REBUILD WITH (FILLFACTOR = 50);
ALTER INDEX ALL ON DAL_T_LOG_LOG_COMP REBUILD WITH (FILLFACTOR = 90);
ALTER INDEX ALL ON DAL_T_LOG_LOG_DATA REBUILD WITH (FILLFACTOR = 50);
ALTER INDEX ALL ON DAL_T_LOG_LOG_PARAMS REBUILD WITH (FILLFACTOR = 50);
ALTER INDEX ALL ON DAL_T_LOG_LOG_SOURCE_IP REBUILD WITH (FILLFACTOR = 90);
UPDATE STATISTICS DAL_T_LOG_LOG_COMP;
UPDATE STATISTICS DAL_T_LOG_LOG_DATA;
UPDATE STATISTICS DAL_T_LOG_LOG_PARAMS;
UPDATE STATISTICS DAL_T_LOG_LOG_SOURCE_IP;
UPDATE STATISTICS DAL_T_LOG_LOG_MESSAGE;
NOTE:
Before running the commands, make sure the log services are down. Once the maintenance is completed, start the services back up.
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