Applies to:
15.x and Newer
Symptom
When posting a certificate to a Microsoft CA you encounter this error:
PostCSR failed with error: Bad Data. (Exception from HRESULT: 0x80090005)
Cause
Inability of the CA to publish its CRL, to check its revocation status, or to access its HSM-protected private key at the time of the certificate request
Resolution
Restart the services on the CA as a workaround, and work with your internal team/Microsoft Support on determining why the CA can't publish it's CRL.
Consider using the Microsoft CA Redundancy feature added in 19.1 if multiple Microsoft CA's are available to use in your environment.
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