Follow

Issue: Creating/Deleting objects in TPP with Windows Server 2016

Applies to:

  • Using Firefox Web Browser or Internet Explorer in WebAdmin or Aperture
    and TPP is installed on a Windows Server 2016 with HTTP/2 enabled.

 

Symptom:

When attempting to create or delete an object in either Webadmin or Aperture an error exception will be shown indicating there was a problem with the action.  

2019-02-19_11-22-15.jpg

ObjectAlreadyExists error as shown above.

2019-02-19_11-32-56.jpg

ObjectDoesNotExist error as shown above.

 

Cause:

Windows Server 2016 installs with HTTP/2 enabled by default.  When using HTTP/2, the TCP/IP connection is established once and there are many calls that can be made within a single connection.  This differs from HTTP/1.1 where a new connection is made for each action needed to load or interact with any given page.  Because of this, HTTP/2 replicates calls when either "creating" or "deleting" objects within TPP.  Ultimately, this leads to misrepresentation of these actions as the replicated call is what is throwing the seen error.

Mozilla are aware of the issue and are investigating.

https://bugzilla.mozilla.org/show_bug.cgi?id=1440479

 

Resolution:

Disable HTTP/2 on TPP servers running Windows Server 2016 by performing the following:

  • Navigate to  HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters
  • Add 2 new REG_DWORD values:
    • EnableHttp2Tls
    • EnableHttp2Cleartext
  • Set both values to 0
  • Reboot the server
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments