Applies to:
Venafi Trust Protection Platform 22.1 or higher after upgrading from 20.1 through 21.4
Symptom:
After upgrading to 22.1 or higher, custom API Integrations cannot have their Name, Description, or Scopes changed.
See screenshot below for example:
Cause:
The reason for this is because vendor field is now a reserved field to be used by Venafi and Venafi Technology Partners. These types of integrations are read only and can only be changed by the vendor responsible for the integration.
If you have custom integrations that you created on earlier versions between 20.1 through 21.4 that contain a value for the vendor field, they will be read-only.
Solution:
There are two options to solving this problem:
Solution #1 - Fixing an Inactive API Integration (not in active use)
If your integration does not have any active grants associated with it, simply delete the integration and recreate it with the same Client ID and scopes as before
Solution #2 - Fixing an API Integration currently in use for production
Run the following Script against your Venafi Platform database. Replace VENDOR NAME with the actual string from the Vendor field of the API Integration that is read only. The script will remove the vendor value from any API Integration that matches the string.
Update oauth_applications set Vendor = '' where Vendor = 'VENDOR NAME'
This second method allows for the integration to be editable again while preserving all issued grants and tokens.
Comments